• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Audi S3 Forum and Audi S3 community dedicated to Audi S3 owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Audi S3 Forum today!

MMI keeps switching on and off by its self randomly

Messages
1
Reactions
0
City
Strathaven
State
Non-US
Country
United Kingdom
What I Drive
S3 2016
#1
Hi folks wondering if anyone has had a problem with the MMi system switching on and off by itself randomly (comes up saying entertainment off on dash screen)
Any advice would be great 😎
I’ve tried the 3 button reset but no joy 😭
I have a 16 plate saloon
 

PaulCH

New member
Messages
1
Reactions
0
City
Gatwick
State
Non-US
Country
United Kingdom
What I Drive
S3 2014
#2
Hi folks wondering if anyone has had a problem with the MMi system switching on and off by itself randomly (comes up saying entertainment off on dash screen)
Any advice would be great 😎
I’ve tried the 3 button reset but no joy 😭
I have a 16 plate saloon
Mine is a 2014 S3. Towards the end of 2019, after the car had stood for 6 weeks, I charged the battery and drove from Gatwick to Liverpool and the MMI was fine, as it always had been. That evening, driving around Liverpool it started switching itself off, just when I really needed the satnav. The 3-button restart worked, but it would still switch off a minute or so later. From then on it did this randomly. One trip would be perfectly fine whereas on the next it would just keep switching off and re-initialising itself until I got fed up and switched it off completely. When it was in at a local Audi specialist they checked for fault codes and said there was nothing relating to the MMI. They suggested that rather than going to Audi I should try a satnav specialist (in Chessington) who said it could cost up to £900, so I decided to live with it for a while. Then lockdown kicked in and I took it off the road for about a year as we have other cars.

I recently started using it again, having kept the battery trickle charged. On the first local journey it was fine and I convinced myself that maybe the 7 year old battery, although fully charged, was not holding its charge and the too-clever electrical system was intermittently shutting down the MMI to save power, although I never got round to checking the battery. I then drove to Devon and the MMI was back to its on/off routine and was unusable. On the way back from Devon I started to get various error messages on the dash screen - hill hold assist not working, ABS system fault, TPMS system fault, headlight distance fault(?). As there was also a transmission vibration I booked it in. The fault codes indicated a faulty rear ABS sensor, which was replaced. This cleared all the faults but it also resolved the MMI issue, which has since behaved faultlessly on a number of trips, including another to Devon and back. I have been using it for as many trips as possible just to see if the fault returns and it hasn't.

I don't know if this will help anyone as I don't understand the link between the MMI and any of the other systems, and until the ABS sensor declared itself faulty there was nothing to indicate that a fault existed elsewhere, other than the erratic MMI behavior.

PS - the transmission vibration was due to the rubber doughnut, which surprised me as the car has done less than 40k. Apparently it delaminates.
 

92683

Moderator
Staff Team
Messages
512
Reactions
31
City
socal.
State
CA
Country
United States
What I Drive
2015 s3
#3
i have mentioned this before, these cars are sensitive to battery voltage and amp output. stock batteries may look good but if its old and has ever died, its no longer as good as it was brand new. always try buying a brand new fresh battery when it comes to these errors.

my experience is with my oem battery doing the same thing. it looked new, started but it was aging at 2 years. mmi would do its error thing. car did start just fine. i was able to get a new one at the time under warranty from the dealership. it no longer did that again.

im watching anything electrical that may show a sign and ill change my battery asap.
 
Messages
1
Reactions
0
City
Murcia
State
Non-US
Country
Spain
What I Drive
Audi s3
#4
Hi folks wondering if anyone has had a problem with the MMi system switching on and off by itself randomly (comes up saying entertainment off on dash screen)
Any advice would be great 😎
I’ve tried the 3 button reset but no joy 😭
I have a 16 plate saloon
Hi I had the same problem sometimes would turn on sometimes not, I spoke to many people about this including Audi who quoted 2000 euros , I eventually spoke to a car radio audio multimedia installer and after taking the car to him he said he would look at it .he said maybe amplifier, so after taking the unit out he opened the unit up and found problems with the soldering which he re did . Cost for this 300 euros but works perfectly now . He said it’s a common problem with these units , not cheap at 300 but a hell of a lot cheaper than Audi ,
 

92683

Moderator
Staff Team
Messages
512
Reactions
31
City
socal.
State
CA
Country
United States
What I Drive
2015 s3
#5
good find on the repair.
for a high end brand they use really horrible parts.

the assumption is that with a weaker battery, the shoddy soldering couldn't hold up. makes you wonder how many other parts of the car is weak components as well.
 

Similar threads



Top