Launch Control

Jae10

New member
#1
Hey Guys, wondering if you could help me out..

So this morning on my way to work I came to a red light with a guy that lives in my area who I've been wanting to catch a red light with for a while.. he's always flying by my house in his little Ford ST.. so I was in sport with the stabilization off.. holding the rev at around 3.5 rpms and when I go to launch on this guy.. my front two tires are spinning and I actually started drifting over to one side a bit.. I finally started getting my grip back and ended whooping on the guy.. but that's besides the point.. This has never happened before.. I always get a really clean smooth launch in my car, I just raced a Golf R about a month ago and because of a great launch I beat the guy pretty good.. I have never heard any peeling out ever.. Almost felt like a college kid again when I had my 2001 Type R.. Please let me know your thoughts..

Also, this just happened and I should go out to my car and see if I need new tires.. but it almost felt more than that. I have about 17,000 miles on the car with the same tires. Any feedback would help. Thanks guys
 
#2
That happened to me a twice as well. Once while trying to show my co-worker the launch control feature and another driving by myself from a red light, I only have 10k miles on my tires. I assumed it was due to the launch control basically turns off all of the car's traction ability.
 

Jae10

New member
#3
What did you do? Is it still happening?
 
#4
Isn't this launch control?
1. Car warmed up and oil temp at least 190 (total guess?)
2. Switch to Dynamic Mode (if not already)
3. Turn off traction and stability controls (press and hold button for 5 seconds)
4. Verify in Sport Mode (S)
5. Firmly hold brake and press throttle till RPM's hover around 4K and then let off brake pedal
 
Last edited:

S3Fan

Administrator
#5
Isn't this launch control?
1. Care warmed up and oil temp at least 190 (total guess?)
2. Switch to Dynamic Mode (if not already)
3. Turn off traction and stability controls (press and hold button for 5 seconds)
4. Verify in Sport Mode (S)
5. Firmly hold brake and press throttle till RPM's hover around 4K and then let off brake pedal
Yup, Ive never had any traction issues with mine.
 
#6
Still haven't tried Launch Control yet and have almost 1,800. :)
 
#9
I've had no issues with mine. It works if you simply press the traction control button once to turn it off, put the shifter in "S", brake and gas. I just leave it in "individual" and it goes like a rocket!
 
#10
Can launch control cause any damage to the car if you use it too much?


Sent from my iPhone using Tapatalk
 
#11
Can launch control cause any damage to the car if you use it too much?


Sent from my iPhone using Tapatalk
It wouldn't damage the car, but it would put some wear on the brakes and transmission.
 
#12
Not according to Audi, but of course too much of anything may result in some failure. If the car is still under warranty I wouldn't concern myself. I use mine maybe 3-4 times each week when exiting a stoplight into open road ahead over the past year and it has never missed a beat. Bear in mind that the 35k service includes servicing the transmission ($700) and thats why I paid $800 for the service contract. At least this is what the dealer told me when I purchased the car.
 

S3Fan

Administrator
#13
Its perfectly safe to use launch control on the S3.
 


Top